Skip to main content
VulnerabilityPublished

CVE-2026-67431: modelcontextprotocol ruby-sdk · Improper Access Control

Affects modelcontextprotocol ruby-sdkSource CVE Database V5

0

Not known to be exploited · CVSS 8.3 High : upgrade to 0.23.0 soon.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.23.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ruby-sdk and mcp to 0.23.0.

Affected software

ProductAffectedFixed in
modelcontextprotocolruby-sdkAffected
  • <0.23.0
Fixed in
  • 0.23.0
RubyGemsmcppkg:gem/mcpOther threatsAffected
  • <0.23.0
Fixed in
  • 0.23.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the MCP Ruby SDK to version 0.23.0 or later, where the issue is fixed by properly binding session IDs to session owners. No other mitigation or temporary workaround is indicated in the available data.

Description

CVE-2026-67431 is a high-severity vulnerability in the MCP Ruby SDK prior to version 0.23.0. The issue involves improper access control where the StreamableHTTPTransport component does not bind session IDs to session owners. This flaw allows an attacker who has obtained a stolen session ID to send requests that execute within the victim's session context. The vulnerability is fixed in version 0.23.0.

References

Community reviews

Loading reviews…