CVE-2026-67434: PHPCSStandards PHP_CodeSniffer · OS Command Injection
Affects PHPCSStandards PHP_CodeSnifferSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 4.0.2 or 3.13.6 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.2, 3.13.6
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade PHP_CodeSniffer and phpcsstandards/PHP_CodeSniffer to 4.0.2 or 3.13.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PHPCSStandardsPHP_CodeSniffer | Affected
| Fixed in
|
| PHPCSStandardsPHP_CodeSniffer | Affected
| Fixed in
|
GitHubphpcsstandards/PHP_CodeSnifferpkg:github/phpcsstandards/PHP_CodeSnifferOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PHP_CodeSniffer to version 3.13.6 or later, or 4.0.2 or later, where this vulnerability is fixed. Avoid running blame report formats (Gitblame, Hgblame, Svnblame) on untrusted files with potentially malicious filenames. Users on platforms that do not allow shell metacharacters in filenames are not affected. Patch status is confirmed fixed in these versions.
Description
PHP_CodeSniffer versions prior to 3.13.6 and 4.0.2 contain a command injection vulnerability in the code generating Gitblame, Hgblame, and Svnblame report formats. This vulnerability allows attacker-controlled shell commands to be executed if a file name contains shell metacharacters and is processed by these blame report formats. Users running default or other non-blame reports, or on platforms that disallow such filenames, are not affected. The issue is fixed in versions 3.13.6 and 4.0.2.
References
- github.com/PHPCSStandards/PHP_CodeSniffer/security/advisories/GHSA-hmqg-cxww-wqhq (opens in a new tab)
- github.com/PHPCSStandards/PHP_CodeSniffer/pull/1473 (opens in a new tab)
- github.com/PHPCSStandards/PHP_CodeSniffer/commit/7a3a6bbf153a03fa3a9413afc60bded6b764e76b (opens in a new tab)
- github.com/PHPCSStandards/PHP_CodeSniffer/commit/f0e1ebb0563f0e5d7f190497a787bcaf8474f3fe (opens in a new tab)
- github.com/PHPCSStandards/PHP_CodeSniffer/releases/tag/3.13.6 (opens in a new tab)
- github.com/PHPCSStandards/PHP_CodeSniffer/releases/tag/4.0.2 (opens in a new tab)