CVE-2026-68433: Linux kernel · libceph: bound get_version reply decode to front len
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.6 High · fixed in 5.15.0-1117.124~20.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +56
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8876-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8878-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8879-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8877-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8875-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8889-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8886-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8875-2 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Linux kernel versions 5.15.0-1117.124 and later related builds. Users should upgrade to these fixed versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
A vulnerability in the Linux kernel's libceph component caused uninitialized memory reads due to improper boundary checks when decoding get_version replies. This flaw allowed decoding beyond the actual received data, potentially exposing stale memory contents. The issue has been fixed in multiple Linux kernel versions starting from 5.15.0-1117.124 and related releases.
References
- ubuntu.com/security/CVE-2026-68433 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-68433 (opens in a new tab)
- git.kernel.org/stable/c/d3c32939fa0e3ee9b883b9a0fd1972c5c444e3d0 (opens in a new tab)
- git.kernel.org/stable/c/340e0386aa39da181015bee38f309018c335ce16 (opens in a new tab)
- git.kernel.org/stable/c/4e7ebfaa0d14cf50e44041bfde38070d6dbc019f (opens in a new tab)
- git.kernel.org/stable/c/0d934c934ec746d53fc7e4f53239792647bbae63 (opens in a new tab)
- git.kernel.org/stable/c/d60de8253c85a02d0e6194b0735e7a562981a04c (opens in a new tab)
- ubuntu.com/security/notices/USN-8876-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8878-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8879-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8877-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8875-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8889-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8886-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8888-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8875-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8887-3 (opens in a new tab)