Skip to main content
VulnerabilityPublished Updated

CVE-2026-68480: Linux kernel · x86/bugs: Make Safe-RET robust against interrupt injection

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · fixed in 5.15.0-1117.124~20.04.1 : update Linux kernel when convenient.

Data as of 28 Oct 2026, 05:11 UTC

Severity
Medium

Rated by Threat Radar · CVSS not yet scored by NVD

EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +41

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-38.38
Fixed in
  • 7.0.0-38.38
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.9
Fixed in
  • 7.0.0-1008.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. Fixed Linux kernel versions include 5.15.0-1117.124~20.04.1 and later. Users should upgrade to these or newer versions to mitigate the vulnerability. No additional mitigation actions are indicated by the vendor advisory.

Description

A vulnerability in the Linux kernel's x86 Safe-RET mitigation allows an attacker to inject interrupts during the Safe-RET sequence, potentially bypassing the mitigation and causing speculative execution data leakage. The issue affects multiple Linux kernel versions prior to specific fixed releases. The vulnerability has been addressed by emulating the Safe-RET sequence on interrupt return to prevent executing a RET instruction that could be exploited.

References

Community reviews

Loading reviews…