Skip to main content
VulnerabilityPublished

CVE-2026-68489: WebPros Plesk extension "Ruby" · Static Code Injection

Affects WebPros Plesk extension "Ruby"Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.6.6 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.6, 2.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Plesk extension to 1.6.6 ("Ruby") or 2.5.0 ("Node.js Toolkit").

Affected software

ProductAffectedFixed in
WebProsPlesk extension "Ruby"Affected
  • <1.6.6
Fixed in
  • 1.6.6
WebProsPlesk extension "Node.js Toolkit"Affected
  • <2.5.0
Fixed in
  • 2.5.0

AI-suggested

In the meantime, restrict access to authenticated users and limit environment variable inputs where possible.

Description

Static Code Injection in Plesk extensions "Ruby" before 1.6.6 and "Node.js Toolkit" before 2.5.0 allows remote authenticated users to execute arbitrary code as root via custom environment variables.

References

Community reviews

Loading reviews…