Skip to main content
VulnerabilityPublished Updated

CVE-2026-69127: getkirby kirby · Exposure of Sensitive System Information to an Unauthorized Control Sphere

Affects getkirby kirbySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 5.5.2 or 4.9.5 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.2, 4.9.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade kirby and getkirby/kirby to 5.5.2 or 4.9.5.

Affected software

ProductAffectedFixed in
getkirbykirbyAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2
getkirbykirbyAffected
  • <4.9.5
Fixed in
  • 4.9.5
GitHubgetkirby/kirbypkg:github/getkirby/kirbyOther threatsAffected
  • <4.9.5
  • >=5.0.0 <5.5.2
Fixed in
  • 4.9.5
  • 5.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Kirby CMS installations to version 4.9.5 or later if using the 4.x branch, or to version 5.5.2 or later if using the 5.x branch. Alternatively, disable the REST API by setting 'api' => false in the configuration to prevent exposure. Patch status is confirmed fixed in these versions.

Description

Kirby is an open-source content management system. Prior to 4.9.5 and from 5.0.0 through 5.5.1, the REST API error handler can return unsanitized PHP error messages that expose the full filesystem path of the Kirby installation to unauthenticated API users. This vulnerability affects all Kirby sites that have not disabled the REST API with the 'api' => false option. This issue is fixed in versions 4.9.5 and 5.5.2.

References

Community reviews

Loading reviews…