Skip to main content
VulnerabilityPublished

CVE-2026-70588: TryGhost Ghost · Cross-site Scripting

Affects TryGhost GhostSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.0 Medium : upgrade to 6.54.1 when convenient.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
5.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.54.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade TryGhost Ghost to 6.54.1.

Affected software

ProductAffectedFixed in
TryGhostGhostAffected
  • >=5.26.0 <6.54.1
Fixed in
  • 6.54.1

AI-suggested

Upgrade Ghost to version 6.54.1 or later, where the vulnerability has been fixed. Since no official remediation level or patch link is provided, users should verify the upgrade from the vendor's official release notes or advisory. No additional mitigation steps are specified.

Description

CVE-2026-70588 is a medium severity cross-site scripting (XSS) vulnerability in the Ghost content management system. The issue affects versions from 5.26.0 up to but not including 6.54.1. It arises from improper sanitization of imported content via the Universal Import feature in Ghost Admin, allowing malicious scripts to be injected into post content. The vulnerability is fixed in version 6.54.1.

References

Community reviews

Loading reviews…