CVE-2026-70653: libvips · Heap-based Buffer Overflow
Affects libvipsSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 8.18.3 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.18.3
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade libvips to 8.18.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| libvips libvips | Affected
| Fixed in
|
Description
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, the old-style Radiance RLE decoder in libvips/foreign/radiance.c can process a repeat marker at the beginning of a scanline in scanline_read_old and read q[-1] before any prior pixel exists. A crafted Radiance image loaded through VipsForeignLoadRad can therefore disclose four bytes of adjacent heap data, most likely other image data. This issue is fixed in version 8.18.3.
References
- github.com/libvips/libvips/security/advisories/GHSA-fh99-55jf-5hj3 (opens in a new tab)
- github.com/libvips/libvips/pull/5037 (opens in a new tab)
- github.com/libvips/libvips/commit/dc945573e15d598054e701c65b90a35b16b19304 (opens in a new tab)
- github.com/libvips/libvips/releases/tag/v8.18.3 (opens in a new tab)