Skip to main content
VulnerabilityPublished Updated

CVE-2026-71253: Apache Johnzon · Unsafe Reflection

Affects Apache JohnzonSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.2.0 or 1.3.1 as a priority.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.0, 1.3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 2.2.0 or 1.3.1.

Affected software

ProductAffectedFixed in
Apache Johnzonorg.apache.johnzon:johnzon-mapperAffected
  • >=2.0.0 <2.2.0
Fixed in
  • 2.2.0
Apache Johnzonorg.apache.johnzon:johnzon-mapperAffected
  • >=1.0.0 <1.3.1
Fixed in
  • 1.3.1
MavenApache Software Foundation/org.apache.johnzon:johnzon-mapperpkg:maven/Apache Software Foundation/org.apache.johnzon:johnzon-mapperOther threatsAffected
  • >=2.0.0 <2.2.0
  • >=1.0.0 <1.3.1
Fixed in
  • 2.2.0
  • 1.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Johnzon to version 1.3.1 (javax namespace) or 2.2.0 (jakarta namespace), which contain fixes for this unsafe reflection vulnerability. No other mitigation is indicated by the vendor advisory.

Description

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Johnzon. ClassConverter loads & static-initializes an attacker-named class from untrusted JSON. This issue affects Apache Johnzon: from 1.0.0 before 2.2.0. Users are recommended to upgrade to version 1.3.1 (javax namespace) or 2.2.0 (jakarta specification namespace), which fixes the issue.

References

Community reviews

Loading reviews…