CVE-2026-71319: nuxt devtools · Code Injection
Affects nuxt devtoolsSource CVE Database V5
Not known to be exploited · CVSS 9.6 Critical : upgrade to 3.3.1 as a priority.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade devtools and nuxt/devtools to 3.3.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nuxtdevtools | Affected
| Fixed in
|
GitHubnuxt/devtoolspkg:github/nuxt/devtoolsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Nuxt DevTools to version 3.3.1 or later, where this vulnerability is fixed. Prior to upgrading, restrict network access to the Vite HMR WebSocket endpoint to trusted clients only, as the channel lacks authentication. Patch status is confirmed fixed in 3.3.1.
Description
A critical code injection vulnerability (CWE-94) exists in Nuxt DevTools versions prior to 3.3.1. The devtools expose an unauthenticated bidirectional RPC channel over the Vite HMR WebSocket, allowing any client with network access to the HMR endpoint to invoke certain RPC methods without authentication. Specifically, the updateOptions() and openInEditor() methods lack proper authentication checks, enabling an attacker to set arbitrary commands and execute them on the developer's machine. This vulnerability is fixed in version 3.3.1.