CVE-2026-7142: Wooey · Improper Authorization
Affects WooeySource CVE Database V5
Public exploit available · CVSS 5.3 Medium · fixed in 0.13.3 : patch Wooey as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.13.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 27 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Wooey | Affected
| Fixed in– |
PyPIwooeypkg:pypi/wooeyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected Wooey installations from versions 0.13.0, 0.13.1, or 0.13.2 to version 0.13.3rc1 or 0.14.0, which contain the official fix for this vulnerability. No other mitigations are indicated.
Description
A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.
References
- vuldb.com/vuln/359741 (opens in a new tab)
- vuldb.com/vuln/359741/cti (opens in a new tab)
- vuldb.com/submit/801533 (opens in a new tab)
- github.com/wooey/Wooey/issues/408 (opens in a new tab)
- github.com/wooey/Wooey/pull/407 (opens in a new tab)
- github.com/wooey/Wooey/commit/f7846fc0c323da8325422cab32623491757f1b88 (opens in a new tab)
- github.com/wooey/Wooey/releases/tag/v0.13.3rc1 (opens in a new tab)
- github.com/wooey/Wooey/ (opens in a new tab)