CVE-2026-71554: python-hyper h2 · HTTP Request/Response Smuggling
Affects python-hyper h2Source CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.4.1 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade python-hyper h2 to 4.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| python-hyperh2 | Affected
| Fixed in
|
PyPIh2pkg:pypi/h2Other threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade python-hyper h2 to version 4.4.1 or later, where this issue is fixed. No other mitigation is indicated by the vendor advisory or data.
Description
python-hyper h2 versions up to and including 4.4.0 have a vulnerability where HTTP/2 request header blocks containing multiple Host headers are accepted and forwarded to the application. When the consumer downgrades HTTP/2 to HTTP/1.1, this results in two Host header lines in the HTTP/1.1 request, enabling HTTP request smuggling. This issue is resolved in version 4.4.1.