Skip to main content
VulnerabilityPublished Updated

CVE-2026-72147: Linux kernel · dmaengine: dw-edma-pcie: Reject devices without driver data

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · fixed in 6.8.0-147.147 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 13:47 UTC

Severity
Low

Rated by Threat Radar · CVSS not yet scored by NVD

EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1014.14~24.04.1 +25

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-38.38
Fixed in
  • 7.0.0-38.38
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.9
Fixed in
  • 7.0.0-1008.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and should be applied to affected Linux kernel versions. Users should update to patched kernel versions to mitigate this vulnerability. No additional mitigation actions are indicated by the vendor advisory.

Description

A vulnerability in the Linux kernel's dmaengine subsystem (dw-edma-pcie driver) was resolved. The issue occurs because the driver unconditionally copies PCI device ID driver_data as a template for the controller layout, which can lead to a NULL pointer dereference if a device bound dynamically via sysfs lacks this data. This flaw has been fixed by rejecting such devices before enabling them. The vulnerability affects specific Linux kernel versions and has a low severity rating.

References

Community reviews

Loading reviews…