Skip to main content
VulnerabilityPublished

CVE-2026-7221: TencentCloudBase CloudBase-MCP · Server-Side Request Forgery

Affects TencentCloudBase CloudBase-MCPSource CVE Database V5

0
Compare

Public exploit available · CVSS 6.9 Medium · fixed in 2.17.1 : patch TencentCloudBase CloudBase-MCP as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.17.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
TencentCloudBaseCloudBase-MCPAffected
  • 2.0 – 2.17.0
18 affected builds
Fixed in–
GitHubtencentcloudbase/CloudBase-MCPpkg:github/tencentcloudbase/CloudBase-MCPOther threatsAffected
  • 2.0 – 2.17.0
18 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade TencentCloudBase CloudBase-MCP to version 2.17.1 or later, which contains the official fix for this SSRF vulnerability. No other mitigations are specified or required once the patch is applied.

Description

CVE-2026-7221 is a server-side request forgery (SSRF) vulnerability in TencentCloudBase CloudBase-MCP versions up to 2.17.0. The vulnerability exists in the openUrl function of the open-url API endpoint, where manipulation of the req.body.url argument allows an attacker to make unauthorized requests from the server. The vulnerability can be exploited remotely without authentication. A patch is available in version 2.17.1 to address this issue.

References

Community reviews

Loading reviews…