Skip to main content
VulnerabilityPublished Updated

CVE-2026-72243: Linux kernel · selinux: check connect-related permissions on TCP

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.4 High · fixed in 6.8.0-147.147 : patch Linux kernel soon.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1014.14~24.04.1 +26
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-38.38
Fixed in
  • 7.0.0-38.38
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.9
Fixed in
  • 7.0.0-1008.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The vulnerability has been fixed in Linux kernel versions 6.8.0-147.147, 6.8.0-1067.70, 7.0.0-1014.14~24.04.1, 6.8.0-1071.79, 7.0.0-1017.17~24.04.1, and other related fixed versions. Users should upgrade to these or later kernel versions to mitigate this issue.

Description

A vulnerability in the Linux kernel SELinux implementation was fixed to ensure connect-related permissions are checked when using TCP Fast Open. Previously, SELinux did not verify these permissions properly during TCP Fast Open connections, potentially allowing unauthorized access. The issue was addressed by updating the socket_sendmsg() hook to call selinux_socket_connect() when MSG_FASTOPEN is used. Several Linux kernel versions prior to the fixed releases are affected.

References

Community reviews

Loading reviews…