Skip to main content
VulnerabilityPublished

CVE-2026-7237: AgiFlow scaffold-mcp · Path Traversal

Affects AgiFlow scaffold-mcpSource CVE Database V5

0
Compare

Public exploit available · CVSS 6.9 Medium.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
AgiFlowscaffold-mcpAffected
  • 1.0.0 – 1.0.27
28 affected builds
Fixed in–
npm@agiflowai/aicode-toolkitpkg:npm/@agiflowai/aicode-toolkitOther threatsAffected
  • <=1.0.27
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade AgiFlow scaffold-mcp to version 1.1.0 or later, which includes the official fix for this path traversal vulnerability. No other mitigations are specified. Patch status is confirmed by the vendor's version upgrade and associated commit.

Description

CVE-2026-7237 is a path traversal vulnerability in AgiFlow scaffold-mcp versions up to 1.0.27. The issue arises from improper handling of the file_path argument in the write-to-file tool component, allowing remote attackers to manipulate file paths. Exploitation can lead to unauthorized file access or modification. A public exploit exists. Upgrading to version 1.1.0 resolves the vulnerability.

References

Community reviews

Loading reviews…