Skip to main content
VulnerabilityPublished Updated

CVE-2026-72397: Linux kernel · hwmon: (pmbus/core) honor vrm_version in pmbus_data2reg_vid()

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-72397· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in 7.0.0-1014.14~24.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1014.14~24.04.1, 7.0.0-1017.17~24.04.1, 7.0.0-1016.16~24.04.1 +12
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-38.38
Fixed in
  • 7.0.0-38.38
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.9
Fixed in
  • 7.0.0-1008.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions. The vendor advisory from Ubuntu confirms that this issue has been fixed in updated linux-aws kernel packages. Users should update to the fixed kernel versions to remediate this vulnerability.

Description

A vulnerability in the Linux kernel's hwmon subsystem (pmbus/core) was resolved, where the function pmbus_data2reg_vid() incorrectly hardcoded the VR11 encoding regardless of the vrm_version configured by the driver. This caused drivers selecting non-VR11 VID modes to send incorrect codes to PMBUS_VOUT_COMMAND, potentially leading to dangerous voltage misconfigurations. The issue was fixed by aligning the write behavior with the read behavior in pmbus_reg2data_vid().

References

Community reviews

Loading reviews…