Skip to main content
VulnerabilityPublished Updated

CVE-2026-72429: Linux kernel · ipv6: ioam: fix type confusion of dst_entry

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 7.0.0-1013.13~24.04.1 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1013.13~24.04.1, 7.0.0-1017.17~24.04.1, 7.0.0-1016.16~24.04.1 +12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-34.34
Fixed in
  • 7.0.0-34.34
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1013.13
Fixed in
  • 7.0.0-1013.13
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.8
Fixed in
  • 7.0.0-1007.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The Ubuntu security advisory USN-8816-1 confirms fixes for this and other Linux kernel vulnerabilities. After updating the kernel packages, a system reboot is required. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary. Follow vendor instructions for updating to the fixed kernel versions.

Description

A type confusion vulnerability in the Linux kernel's IPv6 IOAM implementation was fixed. The issue involved an invalid cast between dst_entry and rt6_info structures, potentially causing invalid pointer access. This flaw was resolved by embedding a full rt6_info structure for the dummy IPv6 route. The vulnerability affects multiple specific linux-hwe-edge kernel versions. A high severity CVSS score of 9.8 indicates critical impact on confidentiality, integrity, and availability. A patch is available and should be applied to mitigate the risk.

References

Community reviews

Loading reviews…