Skip to main content
VulnerabilityPublished

CVE-2026-7260: PHP · Stack-based Buffer Overflow

Affects PHPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium · fixed in 8.5.9 : update PHP when convenient.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.9, 8.4.24, 8.3.33 +1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PHP and the Debian debian/php package to 8.5.9, 8.4.24, 8.3.33 or 8.2.33.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.5.*, < 8.5.9
Fixed in
  • 8.5.9
PHP GroupPHPAffected
  • ≥ 8.4.*, < 8.4.24
Fixed in
  • 8.4.24
PHP GroupPHPAffected
  • ≥ 8.3.*, < 8.3.33
Fixed in
  • 8.3.33
PHP GroupPHPAffected
  • ≥ 8.2.*, < 8.2.33
Fixed in
  • 8.2.33
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • <8.2.33
  • <8.3.33
  • <8.4.24
  • <8.5.9
Fixed in
  • 8.2.33
  • 8.3.33
  • 8.4.24
  • 8.5.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid processing untrusted phar archives containing symbolic links that could be circular.

Description

CVE-2026-7260 is a stack-based buffer overflow vulnerability in PHP caused by circular symbolic links in phar archives. This flaw can trigger unbounded recursion, exhausting the C stack and crashing the PHP process. It affects PHP versions prior to 8.2.33, 8.3.33, 8.4.24, and 8.5.9. The vulnerability has a medium severity rating with a CVSS score of 5.4.

References

Community reviews

Loading reviews…