Skip to main content
VulnerabilityPublished

CVE-2026-7303: Xuxueli xxl-job · Improper Control of Resource Identifiers

Affects Xuxueli xxl-jobSource CVE Database V5

0
Compare

Public exploit available · CVSS 6.3 Medium.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Xuxuelixxl-jobAffected
  • =3.3.0
  • =3.3.1
  • =3.3.2
Fixed in–
Mavencom.xuxueli/xxl-jobpkg:maven/com.xuxueli/xxl-jobOther threatsAffected
  • =3.3.0
  • =3.3.1
  • =3.3.2
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:xuxueli:xxl-job:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the affected Xuxueli xxl-job component to version 3.4.0 or later, which contains the official fix for this vulnerability (commit d24e4ccd6073cc75305e1d3b9c29bc8db7437e7a). Patch status is confirmed by the vendor recommendation. No other mitigation steps are specified.

Description

CVE-2026-7303 is a medium severity vulnerability in Xuxueli xxl-job versions up to 3.3.2. It involves improper control of resource identifiers in the logDetailCat function of the Execution Log Handler component. The vulnerability arises from manipulation of the logId argument, which can be exploited remotely but requires high complexity and no user interaction. An exploit has been publicly released. Upgrading to version 3.4.0 addresses this issue.

References

Community reviews

Loading reviews…