Skip to main content
VulnerabilityPublished

CVE-2026-73070: vim · Stack-based Buffer Overflow

Affects vimSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.8 Medium : upgrade to 9.2.0842 when convenient.

Data as of 29 Oct 2026, 16:21 UTC

CVSS 4.0 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.06.8
Patch
Available – fixed in 9.2.0842
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vim to 9.2.0842.

Affected software

ProductAffectedFixed in
vim vimAffected
  • <9.2.0842
Fixed in
  • 9.2.0842

AI-suggested

Upgrade Vim to version 9.2.0842 or later, where this vulnerability is fixed. No other mitigations are specified or required.

Description

A stack-based buffer overflow vulnerability exists in Vim versions prior to 9.2.0842. The flaw occurs in the socket server backend where unbounded client connections can overflow file descriptor sets and fixed-size pollfd arrays, potentially allowing a local process to corrupt stack memory or terminate the Vim server. This vulnerability is fixed in version 9.2.0842.

References

Community reviews

Loading reviews…