Skip to main content
VulnerabilityPublished

CVE-2026-73511: envoyproxy envoy · Authentication Bypass by Alternate Name

Affects envoyproxy envoySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · fixed in 1.39.1 : update envoyproxy envoy when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.39.1, 1.38.4, 1.37.6 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade envoy and envoyproxy/envoy to 1.39.1, 1.38.4, 1.37.6 or 1.36.10.

Affected software

ProductAffectedFixed in
envoyproxyenvoyAffected
  • >=1.39.0 <1.39.1
Fixed in
  • 1.39.1
envoyproxyenvoyAffected
  • >=1.38.0 <1.38.4
Fixed in
  • 1.38.4
envoyproxyenvoyAffected
  • >=1.37.0 <1.37.6
Fixed in
  • 1.37.6
envoyproxyenvoyAffected
  • <1.36.10
Fixed in
  • 1.36.10
GitHubenvoyproxy/envoypkg:github/envoyproxy/envoyOther threatsAffected
  • <1.36.10
  • >=1.37.0 <1.37.6
  • >=1.38.0 <1.38.4
  • >=1.39.0 <1.39.1
Fixed in
  • 1.36.10
  • 1.37.6
  • 1.38.4
  • 1.39.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Envoy to version 1.36.10, 1.37.6, 1.38.4, or 1.39.1 or later, where this authentication bypass vulnerability is fixed. No other mitigation is required if upgrading is possible.

Description

CVE-2026-73511 is an authentication bypass vulnerability in Envoy proxy caused by inconsistent path matching behavior with backend servers that strip semicolon matrix parameters per path segment. This allows a remote attacker to bypass path-based access controls by crafting requests that cause Envoy to select an unprotected fallback path while the backend resolves the protected resource. The issue affects Envoy versions prior to 1.36.10, 1.37.6, 1.38.4, and 1.39.1 and is fixed in these versions.

References

Community reviews

Loading reviews…