Skip to main content
VulnerabilityPublished Updated

CVE-2026-73513: envoyproxy envoy · Improper Input Validation

Affects envoyproxy envoySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 1.39.1 : patch envoyproxy envoy soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.39.1, 1.38.4, 1.37.6 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade envoy and envoyproxy/envoy to 1.39.1, 1.38.4, 1.37.6 or 1.36.10.

Affected software

ProductAffectedFixed in
envoyproxyenvoyAffected
  • >=1.39.0 <1.39.1
Fixed in
  • 1.39.1
envoyproxyenvoyAffected
  • >=1.38.0 <1.38.4
Fixed in
  • 1.38.4
envoyproxyenvoyAffected
  • >=1.37.0 <1.37.6
Fixed in
  • 1.37.6
envoyproxyenvoyAffected
  • <1.36.10
Fixed in
  • 1.36.10
GitHubenvoyproxy/envoypkg:github/envoyproxy/envoyOther threatsAffected
  • <1.36.10
  • >=1.37.0 <1.37.6
  • >=1.38.0 <1.38.4
  • >=1.39.0 <1.39.1
Fixed in
  • 1.36.10
  • 1.37.6
  • 1.38.4
  • 1.39.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Envoy to version 1.36.10, 1.37.6, 1.38.4, or 1.39.1 or later to apply the official fix. No other mitigation is indicated. The default nghttp2 codec is not vulnerable, so disabling oghttp2 codec may be a temporary workaround if upgrading is not immediately possible.

Description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.36.10, 1.37.6, 1.38.4, and 1.39.1, Envoy's optional oghttp2 upstream HTTP/2 codec accepts a response trailer HEADERS frame without END_STREAM. Envoy completes and deferred-deletes the ActiveRequest while oghttp2 keeps the stream open, leaving ClientStreamImpl with a dangling response_decoder_ reference. A later frame on the stream can dispatch through the freed object and crash the process. The relevant scope boundary is that the default nghttp2 codec rejects the malformed trailers, and the trigger is upstream-only with oghttp2 enabled. This issue is fixed in versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1.

References

Community reviews

Loading reviews…