Skip to main content
VulnerabilityPublished

CVE-2026-73579: Apache Syncope · Incorrect Authorization

Affects Apache SyncopeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical · fixed in 4.0.8 : patch Apache Syncope as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache SyncopeAffected
  • >=3.0.0-M0 <=3.0.16
  • >=4.0.0-M0 <=4.0.7
  • >=4.1.0-M0 <=4.1.2
Fixed in–
MavenApache Software Foundation/org.apache.syncope.core:syncope-core-persistence-commonpkg:maven/Apache Software Foundation/org.apache.syncope.core:syncope-core-persistence-commonOther threatsAffected
  • >=3.0.0-M0 <=3.0.16
  • >=4.0.0-M0 <=4.0.7
  • >=4.1.0-M0 <=4.1.2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Syncope to versions 4.0.8 or 4.1.3, where this incorrect authorization issue is fixed. No other mitigation steps are specified or required once the upgrade is applied.

Description

Incorrect Authorization vulnerability in Apache Syncope. Any search requests are transformed into SQL, Neo4J or Elasticsearch / Opensearch queries, depending on the actual deployment configuration. An important component of such transformation is the Realms filter, which ensures that the search results are matching the requester's permissions. For non-recursive search requests it is possible that such Realms filter is rendered as empty, thus voiding any restriction on requester privileges. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

References

Community reviews

Loading reviews…