Skip to main content
VulnerabilityPublished Updated

CVE-2026-73639: Imager (Perl module) · Out-of-bounds Write

Affects Imager (Perl module)Source CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.035 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-09-22.

Patch
Available – fixed in 1.004, 1.035
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Imager to 1.035; Imager-File-PNG to 1.004.

Affected software

ProductAffectedFixed in
Imager-File-PNGAffected
  • >=1.003 <1.004
Fixed in
  • 1.004
ImagerAffected
  • >=1.034 <1.035
Fixed in
  • 1.035
CPANImager-File-PNGpkg:cpan/Imager-File-PNGOther threatsAffected
  • >=1.003 <1.004
Fixed in
  • 1.004
CPANImagerpkg:cpan/ImagerOther threatsAffected
  • >=1.034 <1.035
Fixed in
  • 1.035

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions 1.004 and 1.035 of Imager address this vulnerability. Users should upgrade to at least version 1.004 or 1.035 depending on their current version to remediate this issue. No other mitigation or workaround is indicated.

Description

CVE-2026-73639 is a critical out-of-bounds write vulnerability in the Imager Perl module's PNG file reader. Versions from 1.003 before 1.004 and 1.034 before 1.035 improperly size the row buffer when reading PNG images with a tRNS transparency chunk, causing heap corruption and potential process crashes.

References

Community reviews

Loading reviews…