Skip to main content
VulnerabilityPublished Updated

CVE-2026-74415: Linux kernel · spi: atcspi200: fix use-after-free when driver unbind

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · fixed in 7.0.0-1014.14~24.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 17:16 UTC

Severity
Medium

Rated by Threat Radar · CVSS not yet scored by NVD

EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1014.14~24.04.1, 7.0.0-1017.17~24.04.1, 7.0.0-1016.16~24.04.1 +11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-38.38
Fixed in
  • 7.0.0-38.38
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.9
Fixed in
  • 7.0.0-1008.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and should be applied to affected Linux kernel versions to remediate this vulnerability. Users should update to patched kernel versions as listed by their distribution. No additional mitigation steps are indicated by the vendor advisory.

Description

A use-after-free vulnerability was identified and fixed in the Linux kernel's spi: atcspi200 driver. The flaw occurs when the driver unbinds and the DMA resource is torn down while the SPI controller remains active, potentially leading to use-after-free conditions during DMA transfers. Multiple specific Linux kernel versions are affected. A patch is available to address this issue.

References

Community reviews

Loading reviews…