Skip to main content
VulnerabilityPublished

CVE-2026-75056: JetBrains IntelliJ IDEA · OS Command Injection

Affects JetBrains IntelliJ IDEASource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 2026.2.1 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-08-17.

Patch
Available – fixed in 2026.2.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade JetBrains IntelliJ IDEA to 2026.2.1.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • <2026.2.1
Fixed in
  • 2026.2.1

AI-suggested

Users should upgrade to JetBrains IntelliJ IDEA version 2026.2.1 or later, where this vulnerability has been fixed. No other mitigation or workaround is indicated in the available data.

Description

CVE-2026-75056 is a high-severity vulnerability in JetBrains IntelliJ IDEA prior to version 2026.2.1. It involves a remote code execution (rCE) flaw via the Markdown export tool. The vulnerability is identified as CWE-78, which relates to improper neutralization of special elements used in a command ('Command Injection').

References

Community reviews

Loading reviews…