CVE-2026-75604: vercel next.js · Path Traversal
Affects vercel next.jsSource CVE Database V5
Public exploit available (Metasploit) · CVSS 9.0 Critical : upgrade to 16.3.3 or 15.5.24 as a priority.
Data as of 26 Oct 2026, 12:29 UTC
- EPSS
- 2.1% chance of exploitation in 30 days – higher than 81% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-09-03.
- Patch
- Available – fixed in 16.3.3, 15.5.24
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vercel next.js to 16.3.3 or 15.5.24.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vercelnext.js | Affected
| Fixed in
|
| vercelnext.js | Affected
| Fixed in
|
AI-suggested
Upgrade Next.js to version 15.5.24 or later in the 15.x series, or to version 16.3.3 or later in the 16.x series to apply the official fix for this vulnerability. No other mitigation is indicated by the vendor advisory.
Description
Next.js versions from 13.4.0 up to but not including 15.5.24, and from 16.0.0 up to but not including 16.3.3, contain a path traversal vulnerability on Windows-hosted servers. This flaw allows remote attackers to supply encoded Windows path separators that bypass intended cache directory restrictions, exposing private build data including a critical encryption key. Disclosure of this key can lead to remote code execution. The issue is fixed in versions 15.5.24 and 16.3.3.
References
- github.com/vercel/next.js/security/advisories/GHSA-p293-qw3h-jr36 (opens in a new tab)
- github.com/vercel/next.js/commit/968b9fcb26bdeb8e0a861a9df05361474666d51b (opens in a new tab)
- github.com/vercel/next.js/commit/b0f3460a92b955d3ca41fccff9a525a2b910fbf3 (opens in a new tab)
- github.com/vercel/next.js/releases/tag/v15.5.24 (opens in a new tab)
- github.com/vercel/next.js/releases/tag/v16.3.3 (opens in a new tab)