Skip to main content
VulnerabilityPublished

CVE-2026-75614: esa asn1scc · Improper Validation of Array Index

Affects esa asn1sccSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 4.7.0.1 soon.

Data as of 5 Nov 2026, 17:04 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.18.1
Patch
Available – fixed in 4.7.0.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade esa asn1scc to 4.7.0.1.

Affected software

ProductAffectedFixed in
esaasn1sccAffected
  • <4.7.0.1
Fixed in
  • 4.7.0.1

AI-suggested

Upgrade to esa asn1scc version 4.7.0.1 or later, where this vulnerability is fixed.

Description

CVE-2026-75614 is a high-severity vulnerability in the esa asn1scc ASN.1 compiler for embedded systems. Versions prior to 4.7.0.1 improperly validate array indices during decoding of constrained integers, allowing crafted input to cause buffer overflows. This can lead to memory corruption, crashes, or potential code execution. The issue is fixed in version 4.7.0.1.

References

Community reviews

Loading reviews…