Skip to main content
VulnerabilityPublished Updated

CVE-2026-76186: Apache Airflow Keycloak provider · Unvalidated Cookie Trust

Affects Apache Airflow Keycloak providerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.10.0 as a priority.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow Keycloak provider and apache-airflow-providers-keycloak to 0.10.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Airflow Keycloak providerAffected
  • <0.10.0
Fixed in
  • 0.10.0
PyPIapache-airflow-providers-keycloakpkg:pypi/apache-airflow-providers-keycloakOther threatsAffected
  • <0.10.0
Fixed in
  • 0.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade apache-airflow-providers-keycloak to version 0.10.0 or later, which implements binding of Keycloak tokens to the session identity, preventing mismatched token usage. This is the official fix provided by the vendor. No other mitigation is indicated or necessary once upgraded.

Description

Apache Airflow Keycloak provider versions before 0.10.0 have a security flaw where Keycloak access and refresh tokens are stored in separate unauthenticated cookies without validation against the signed Airflow session token. This allows an attacker with a valid Airflow login and a foreign Keycloak token to gain unauthorized privileges while maintaining their own session identity. The issue affects Airflow 3.3 or later deployments using the vulnerable Keycloak provider versions. Upgrading to apache-airflow-providers-keycloak 0.10.0 or later mitigates this vulnerability by binding tokens to the session identity.

References

Community reviews

Loading reviews…