CVE-2026-7630: innocommerce InnoShop · Improper Authentication
Affects innocommerce InnoShopSource CVE Database V5
Public exploit available · CVSS 6.9 Medium : upgrade to 0.7.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.7.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 2 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade innocommerce/innoshop to 0.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| innocommerceInnoShop | Affected
| Fixed in– |
GitHubinnocommerce/innoshoppkg:github/innocommerce/innoshopOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability, identified by commit 45758e4ec22451ab944ae2ae826b1e70f6450dc9. Since InnoShop is a cloud-hosted service, the vendor generally manages remediation and patch deployment server-side. Users should verify with the vendor's advisory or support channels to confirm that the patch has been applied to their environment. Patch status is confirmed available; applying the official fix is recommended.
Description
A vulnerability has been found in innocommerce InnoShop up to 0.7.8. The affected element is the function InstallServiceProvider::boot of the file innopacks/install/src/InstallServiceProvider.php of the component Installation Endpoint. The manipulation leads to improper authentication. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. The identifier of the patch is 45758e4ec22451ab944ae2ae826b1e70f6450dc9. It is recommended to apply a patch to fix this issue.
References
- vuldb.com/vuln/360576 (opens in a new tab)
- vuldb.com/vuln/360576/cti (opens in a new tab)
- vuldb.com/submit/806484 (opens in a new tab)
- github.com/innocommerce/innoshop/issues/314 (opens in a new tab)
- github.com/innocommerce/innoshop/issues/314 (opens in a new tab)
- github.com/innocommerce/innoshop/commit/45758e4ec22451ab944ae2ae826b1e70f6450dc9 (opens in a new tab)
- github.com/innocommerce/innoshop/ (opens in a new tab)