CVE-2026-76825: zopefoundation RestrictedPython · Information Exposure
Affects zopefoundation RestrictedPythonSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 8.4 soon.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.4
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade RestrictedPython and restrictedpython to 8.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| zopefoundationRestrictedPython | Affected
| Fixed in
|
PyPIrestrictedpythonpkg:pypi/restrictedpythonOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to RestrictedPython version 8.4 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-76825 is a vulnerability in zopefoundation's RestrictedPython prior to version 8.4 that allows sandbox escape. The issue arises when restricted code can access the standard library string module's Formatter class or instances, which internally perform attribute and item traversal without RestrictedPython's safer_getattr protections. This enables restricted code to reach sensitive objects such as function globals, builtins, file access, or code execution primitives, compromising confidentiality, integrity, and availability. The vulnerability is fixed in version 8.4.