CVE-2026-77053: boneIO · Missing Authentication
Affects boneIOSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 1.6.0 soon.
Data as of 26 Oct 2026, 16:53 UTC
- Patch
- Available – fixed in 1.6.0
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade boneIO and boneio to 1.6.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| boneIOboneio | Affected
| Fixed in
|
GitHubboneiopkg:github/boneioOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade all affected boneIO devices to version 1.6.0 or later, which enforces administrator account creation and restricts API access to authenticated users. For devices running versions prior to 1.2.0, re-flash the device with the 1.6.0 system image as in-place upgrades are not supported. No other mitigations are indicated.
Description
boneIO Black firmware versions prior to 1.6.0 have authentication disabled by default on their management web API, exposing all endpoints without requiring credentials. This allows unauthenticated remote attackers to fully control the device, including causing denial of service, modifying configurations, and operating connected physical circuits. The issue was fixed in version 1.6.0 by requiring an administrator account creation during the first-run wizard and restricting API routes to authenticated roles. Versions before 1.2.0 are based on Debian 10, unsupported, and cannot be upgraded in place; affected devices must be re-flashed with the 1.6.0 system image.