Skip to main content
VulnerabilityPublished Updated

CVE-2026-7713: crocodilestick Calibre-Web-Automated · Improper Authorization

Affects crocodilestick Calibre-Web-AutomatedSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium · fixed in 4.0.7 : patch crocodilestick Calibre-Web-Automated as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
crocodilestickCalibre-Web-AutomatedAffected
  • 4.0.0 – 4.0.6
7 affected builds
Fixed in–
GitHubcrocodilestick/Calibre-Web-Automatedpkg:github/crocodilestick/Calibre-Web-AutomatedOther threatsAffected
  • 4.0.0 – 4.0.6
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade crocodilestick Calibre-Web-Automated to version 4.0.7 or later, which contains the official fix for this vulnerability. No other mitigation steps are indicated by the vendor advisory.

Description

A vulnerability was detected in crocodilestick Calibre-Web-Automated up to 4.0.6. Affected by this vulnerability is the function generate_auth_token of the file cps/kobo_auth.py of the component Kobo auth-token Route. The manipulation results in improper authorization. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.0.7 addresses this issue. The patch is identified as 9f50bb2c16160564c9f8777dc2ceed3eb95e4807. The affected component should be upgraded.

References

Community reviews

Loading reviews…