Skip to main content
VulnerabilityPublished

CVE-2026-77243: sooperset mcp-atlassian · Missing Authorization

Affects sooperset mcp-atlassianSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 0.22.0 soon.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.22.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade mcp-atlassian and sooperset/mcp-atlassian to 0.22.0.

Affected software

ProductAffectedFixed in
soopersetmcp-atlassianAffected
  • <0.22.0
Fixed in
  • 0.22.0
GitHubsooperset/mcp-atlassianpkg:github/sooperset/mcp-atlassianOther threatsAffected
  • <0.22.0
Fixed in
  • 0.22.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to version 0.22.0 or later where this authorization issue is fixed. No other mitigation or temporary workaround is indicated in the advisory. Patch status is confirmed fixed in 0.22.0.

Description

CVE-2026-77243 is a missing authorization vulnerability in sooperset's mcp-atlassian server affecting versions prior to 0.22.0. The flaw allows clients who know hidden tool names to invoke restricted read, write, or delete operations despite least-privilege configurations. This occurs because ENABLED_TOOLS and TOOLSETS are checked when listing tools but not rechecked when dispatching tool calls. The issue is fixed in version 0.22.0.

References

Community reviews

Loading reviews…