Skip to main content
VulnerabilityPublished Updated

CVE-2026-7725: PrefectHQ prefect · Argument Injection

Affects PrefectHQ prefectSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium · fixed in 3.6.25 : patch PrefectHQ prefect as a priority.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.6.25
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
PrefectHQprefectAffected
  • =3.6.25.dev6
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:prefect:prefect:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PrefectHQ prefect to version 3.6.25.dev7 or later, which contains the official fix for this vulnerability. Since the vendor has released a patched version promptly, applying this update is the recommended remediation.

Description

CVE-2026-7725 is a medium severity vulnerability in PrefectHQ's prefect up to version 3.6.25.dev6. It involves argument injection through manipulation of the commit_sha or directories arguments in the GitRepository Pull Handler component. The vulnerability can be exploited remotely without user interaction. A fixed version, 3.6.25.dev7, has been released by the vendor to address this issue.

References

Community reviews

Loading reviews…