Skip to main content
VulnerabilityPublished

CVE-2026-77274: sooperset mcp-atlassian · Server-Side Request Forgery (SSRF)

Affects sooperset mcp-atlassianSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 0.22.0 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.22.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade mcp-atlassian and sooperset/mcp-atlassian to 0.22.0.

Affected software

ProductAffectedFixed in
soopersetmcp-atlassianAffected
  • <0.22.0
Fixed in
  • 0.22.0
GitHubsooperset/mcp-atlassianpkg:github/sooperset/mcp-atlassianOther threatsAffected
  • <0.22.0
Fixed in
  • 0.22.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade MCP Atlassian to version 0.22.0 or later, where this SSRF vulnerability is fixed. No other mitigations are specified or required once the official fix is applied.

Description

CVE-2026-77274 is a high-severity Server-Side Request Forgery (SSRF) vulnerability in the MCP Atlassian server used for Atlassian products like Confluence and Jira. Versions prior to 0.22.0 have a flaw in the validate_url_for_ssrf function, which misinterprets URL authority due to backslash confusion. This allows an attacker to craft a URL that appears external but causes the server to connect to internal protected network resources. The issue is fixed in version 0.22.0.

References

Community reviews

Loading reviews…