CVE-2026-7737: osrg GoBGP · Out-of-bounds Read
Affects osrg GoBGPSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium · fixed in 4.4.0 : update osrg GoBGP when convenient.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:XExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| osrgGoBGP | Affected
| Fixed in– |
Gogithub.com/osrg/gobgppkg:golang/github.com/osrg/gobgpOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:osrg:gobgp:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrading the affected GoBGP component to version 4.4.0 is recommended to remediate this vulnerability. The patch is identified by commit bc77597d42335c78464bc8e15a471d887bbdf260. No other mitigation or temporary fixes are indicated.
Description
A vulnerability was identified in osrg GoBGP up to 4.3.0. Affected by this issue is the function BMPPeerUpNotification.ParseBody/BMPStatisticsReport.ParseBody of the file pkg/packet/bmp/bmp.go of the component BMP Parser. The manipulation leads to out-of-bounds read. The attack can be initiated remotely. Upgrading to version 4.4.0 can resolve this issue. The identifier of the patch is bc77597d42335c78464bc8e15a471d887bbdf260. Upgrading the affected component is recommended.
References
- vuldb.com/vuln/360912 (opens in a new tab)
- vuldb.com/vuln/360912/cti (opens in a new tab)
- vuldb.com/submit/807605 (opens in a new tab)
- github.com/osrg/gobgp/commit/bc77597d42335c78464bc8e15a471d887bbdf260 (opens in a new tab)
- github.com/osrg/gobgp/releases/tag/v4.4.0 (opens in a new tab)
- github.com/osrg/gobgp/ (opens in a new tab)