CVE-2026-77411: rabbitmq amqp091-go · Unchecked Error Condition
Affects rabbitmq amqp091-goSource CVE Database V5
Not known to be exploited · CVSS 9.5 Critical : upgrade to 1.13.0 as a priority.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.13.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade amqp091-go and rabbitmq/amqp091-go to 1.13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rabbitmqamqp091-go | Affected
| Fixed in
|
GitHubrabbitmq/amqp091-gopkg:github/rabbitmq/amqp091-goOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade RabbitMQ amqp091-go to version 1.13.0 or later, where this issue is fixed. No other mitigation is indicated or required according to the available information.
Description
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, readLongstr in read.go returns an empty string and a nil error when a declared AMQP longstr length exceeds 0x7FFFFFFF instead of returning ErrSyntax. The function leaves the declared field bytes unread, while readTable treats the operation as successful and continues parsing from the wrong offset. A malicious or compromised broker can provide an oversized longstr in a table field and desynchronize subsequent AMQP parsing, causing attacker-controlled trailing bytes to be interpreted as later fields or frames and disrupting connection integrity and availability. This issue is fixed in version 1.13.0.
References
- github.com/rabbitmq/amqp091-go/security/advisories/GHSA-c5pq-fr2g-9jpf (opens in a new tab)
- github.com/rabbitmq/amqp091-go/pull/347 (opens in a new tab)
- github.com/rabbitmq/amqp091-go/commit/143c1ace5fa7344cee135e5c7d22970f0de68282 (opens in a new tab)
- github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0 (opens in a new tab)