Skip to main content
VulnerabilityPublished

CVE-2026-77423: jline jline3 · ReDoS

Affects jline jline3Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 4.3.1 or 3.30.15 soon.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.1, 3.30.15
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade jline3 and org.jline/jline3 to 4.3.1 or 3.30.15.

Affected software

ProductAffectedFixed in
jlinejline3Affected
  • >=4.0.0 <4.3.1
Fixed in
  • 4.3.1
jlinejline3Affected
  • >=3.0.0 <3.30.15
Fixed in
  • 3.30.15
Mavenorg.jline/jline3pkg:maven/org.jline/jline3Other threatsAffected
  • >=3.0.0 <3.30.15
  • >=4.0.0 <4.3.1
Fixed in
  • 3.30.15
  • 4.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in JLine3 versions 3.30.15 and 4.3.1. Users should upgrade to these or later versions to remediate the vulnerability. No additional vendor advisory content is provided, so patching to the fixed versions is the recommended mitigation.

Description

JLine3 versions from 3.0.0 up to but not including 3.30.15, and from 4.0.0 up to but not including 4.3.1, contain an inefficient regular expression complexity vulnerability. The built-in less viewer passes user-controlled search and filter patterns directly to Java's backtracking regex engine, which can cause excessive CPU consumption and indefinite blocking of the session thread when processing certain inputs. This can lead to denial of service by exhausting worker threads in Telnet or SSH deployments. The issue is fixed in versions 3.30.15 and 4.3.1.

References

Community reviews

Loading reviews…