CVE-2026-77756: Apache Tomcat · HTTP Request/Response Smuggling
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · CVSS 3.7 Low.
Data as of 7 Nov 2026, 23:24 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Tomcat | Affected
| Fixed in– |
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache Tomcat versions to 11.0.26, 10.1.60, 9.0.122, or later, which contain fixes for this vulnerability. No other mitigation actions are specified or required. Patch status is confirmed as fixed in these versions.
Description
CVE-2026-77756 is a medium severity vulnerability in Apache Tomcat involving inconsistent interpretation of HTTP requests, specifically HTTP Request/Response Smuggling. The issue arises from how the transfer-encoding header is processed for HTTP/1.0 requests when Tomcat is behind a reverse proxy, potentially causing one user's request to fail due to another user's request. Affected versions include Apache Tomcat 8.5.67 through 8.5.100, 9.0.47 through 9.0.121, 10.1.0-M1 through 10.1.59, and 11.0.0-M1 through 11.0.25. Users are advised to upgrade to fixed versions 8.5.101 or later, 9.0.122 or later, 10.1.60 or later, or 11.0.26 or later to remediate the issue.