CVE-2026-77762: Apache Tomcat · Race Condition
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · fixed in 8.5.101 : patch Apache Tomcat soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.5.101
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Tomcat | Affected
| Fixed in– |
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache Tomcat versions to 11.0.26, 10.1.60, or 9.0.122 or later, where the vulnerability is fixed. Applying these official updates is the recommended and effective mitigation.
Description
A race condition vulnerability (CWE-362) in Apache Tomcat allows an attacker to inject trailer fields into another HTTP/2 request due to improper synchronization of shared resources. This affects multiple versions of Apache Tomcat including 8.5.59 through 8.5.100, 9.0.39 through 9.0.121, 10.1.0-M1 through 10.1.59, and 11.0.0-M1 through 11.0.25. The issue is fixed in versions 8.5.101 and later, 9.0.122 and later, 10.1.60 and later, and 11.0.26 and later. The vulnerability has a high severity with a CVSS score of 8.1.