CVE-2026-77811: OpenSearch Dashboards dashboards-observability plugin · Cross-site Scripting
Affects OpenSearch Dashboards dashboards-observability pluginSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 3.4 or 2.19.6 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-08-27.
- Patch
- Available – fixed in 3.4, 2.19.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade OpenSearch Dashboards dashboards-observability plugin to 3.4 or 2.19.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenSearchOpenSearch Dashboards dashboards-observability plugin | Affected
| Fixed in
|
| OpenSearchOpenSearch Dashboards dashboards-observability plugin | Affected
| Fixed in
|
AI-suggested
Upgrade OpenSearch Dashboards to version 3.4 or later, or 2.19.6 or later, where this vulnerability has been fixed. No additional vendor advisory indicates alternative mitigations or that no action is required.
Description
CVE-2026-77811 is a high-severity cross-site scripting (XSS) vulnerability in the dashboards-observability plugin of OpenSearch Dashboards. It allows a remote authenticated user with write permissions to execute arbitrary JavaScript in other users' browser sessions by uploading a saved asset containing malicious web content. This vulnerability affects versions prior to 3.4 and 2.19.6 and has been fixed in those releases.
Reports on CVE-2026-77811
References
- opensearch.org/artifacts/by-version/ (opens in a new tab)
- opensearch.org/artifacts/by-version/ (opens in a new tab)
- aws.amazon.com/security/security-bulletins/2026-088-aws/ (opens in a new tab)
- github.com/opensearch-project/dashboards-observability/security/advisories/GHSA-rmqx-r3wm-3px5 (opens in a new tab)