Skip to main content
VulnerabilityPublished

CVE-2026-7814: pgAdmin 4 · Cross-site Scripting

Affects pgAdmin 4Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 9.15 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.15
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.15.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • >=6.9 <9.15
Fixed in–
GitHubpgadmin-org/pgadmin4pkg:github/pgadmin-org/pgadmin4Other threatsAffected
  • =6.9
Fixed in–
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • >=6.9 <9.15
Fixed in
  • 9.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is fixed in pgAdmin 4 version 9.15 by replacing innerHTML with textContent. If you cannot patch yet, users should avoid interacting with untrusted PostgreSQL objects with potentially malicious names. Monitor pgAdmin.org for updates and apply the official fix once released.

Description

Stored cross-site scripting (XSS) vulnerability in pgAdmin 4 Browser Tree and Explain Visualizer modules. User-controlled PostgreSQL object names (database, schema, table, column, etc.) were assigned to DOM elements via innerHTML, allowing crafted object names containing HTML markup to execute attacker-supplied JavaScript in the browser of any pgAdmin user who navigated to or executed EXPLAIN over the malicious object. Fix replaces innerHTML with textContent. This issue affects pgAdmin 4: before 9.15.

References

Community reviews

Loading reviews…