Skip to main content
VulnerabilityPublished Updated

CVE-2026-7816: pgAdmin 4 · OS Command Injection

Affects pgAdmin 4Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 9.15 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.4% chance of exploitation in 30 days – higher than 73% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.15.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • >=9.4 <9.15
Fixed in–
GitHubpgadmin-org/pgadmin4pkg:github/pgadmin-org/pgadmin4Other threatsAffected
  • =9.4
Fixed in–
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • >=9.4 <9.15
Fixed in
  • 9.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in pgAdmin 4 version 9.15 which addresses this vulnerability by sanitizing inputs and enforcing strict parsing and validation. Users should upgrade to version 9.15 or later to remediate this issue. Patch status is not explicitly confirmed in the provided data, but the vendor has released a fixed version. No additional mitigations are specified.

Description

OS command injection (CWE-78) vulnerability in pgAdmin 4 Import/Export query export. User-supplied input was interpolated directly into a psql \copy metacommand template without sanitization. An authenticated user could inject ") TO PROGRAM 'cmd'" to break out of the \copy (...) context and achieve arbitrary command execution on the pgAdmin server, or ") TO '/path'" for arbitrary file write. Additional fields (format, on_error, log_verbosity) were also raw-interpolated and exploitable. Fix adds a parens-balance parser modeled on psql's strtokx tokenizer, allow-lists format/on_error/log_verbosity, rejects null bytes in the query, and tightens type and gating checks. This issue affects pgAdmin 4: before 9.15.

References

Community reviews

Loading reviews…