Skip to main content
VulnerabilityPublished

CVE-2026-7817: pgAdmin 4 · Exposed Files or Directories

Affects pgAdmin 4Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 9.15 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.15.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • >=9.13 <9.15
Fixed in–
GitHubpgadmin-org/pgadmin4pkg:github/pgadmin-org/pgadmin4Other threatsAffected
  • =9.13
Fixed in–
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • >=9.13 <9.15
Fixed in
  • 9.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The described fix restricts file access and URL targets to mitigate the vulnerability. Users should upgrade to pgAdmin 4 version 9.15 or later once available. Until then, restrict access to authenticated users only and monitor for unusual activity related to LLM API configuration endpoints.

Description

Local file inclusion (LFI) and server-side request forgery (SSRF) vulnerabilities in pgAdmin 4 LLM API configuration endpoints. User-supplied api_key_file and api_url preferences were passed to the LLM provider clients without validation. An authenticated user could read arbitrary server-side files by pointing api_key_file at any path readable by the pgAdmin process, or coerce pgAdmin into making requests to internal targets (e.g.cloud metadata services such as 169.254.169.254) by setting api_url, exploiting the chat path and model-list endpoints. Fix restricts api_key_file to the user's private storage (server mode) or home directory (desktop mode), enforces a printable-ASCII key shape and a 1024-byte read cap, and gates api_url against a configurable allow-list (config.ALLOWED_LLM_API_URLS) at every entry point. This issue affects pgAdmin 4: before 9.15.

References

Community reviews

Loading reviews…