CVE-2026-78190: WebDyne (Perl module) · Cross-site Scripting
Affects WebDyne (Perl module)Source CVE Database V5
Not known to be exploited : upgrade to 3.022 soon.
Data as of 31 Oct 2026, 14:53 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 3.022
Exploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade WebDyne (Perl module) to 3.022.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WebDyne | Affected
| Fixed in
|
CPANWebDynepkg:cpan/WebDyneOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade WebDyne to version 3.022 or later, where this vulnerability is fixed. Since the vulnerability is addressed in this fixed version, applying this official update is the recommended remediation.
Description
WebDyne versions from 2.014 up to but not including 3.022 contain a cross-site scripting (XSS) vulnerability. This occurs because certain form tags (textfield, password_field, filefield) reflect request parameters into their value attributes without proper escaping. The default escaping control (WEBDYNE_CGI_AUTOESCAPE) is off, and from version 2.022 the entity encoding method was replaced with a no-op, rendering escaping ineffective. An attacker can inject malicious scripts via crafted links using these tags.