CVE-2026-7849: Phoenix Contact CHARX SEC-3150 · Command Injection
Affects Phoenix Contact CHARX SEC-3150Source CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.9.1 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers can reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-07-30.
- Patch
- Available – fixed in 1.9.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade CHARX to 1.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Phoenix ContactCHARX SEC-3150 | Affected
| Fixed in
|
| Phoenix ContactCHARX SEC-3100 | Affected
| Fixed in
|
| Phoenix ContactCHARX SEC-3050 | Affected
| Fixed in
|
| Phoenix ContactCHARX SEC-3000 | Affected
| Fixed in
|
AI-suggested
Upgrade the CHARX SEC-3150 device to version 1.9.1 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-7849 is a critical command injection vulnerability in Phoenix Contact's CHARX SEC-3150 device. An unauthenticated remote attacker can inject commands into the system configuration, which are executed with root privileges. This flaw affects versions 1.0.0 up to but not including 1.9.1. The issue is fixed in version 1.9.1.