CVE-2026-79591: libxls · CVE-2026-79591 is a high-severity
Affects libxlsSource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 1.6.3 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade libxls/libxls to 1.6.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublibxls/libxlspkg:github/libxls/libxlsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid processing untrusted XLS files with vulnerable versions of libxls.
Description
CVE-2026-79591 is a high-severity vulnerability in libxls version 1.6.3 and earlier. It involves a heap-buffer-overflow and use-after-free in the xls_getCSS() function caused by insufficient validation of a file-controlled font index. This flaw can lead to high impact on confidentiality, integrity, and availability if exploited.