Skip to main content
VulnerabilityPublished Updated

CVE-2026-80593: Linux kernel · hwmon: (asus_atk0110) Check package count before accessing element

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.4 High · fixed in 5.15.0-1117.124~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +40
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-38.38
Fixed in
  • 7.0.0-38.38
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1017.17
Fixed in
  • 7.0.0-1017.17
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.9
Fixed in
  • 7.0.0-1008.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability and should be applied promptly. The vendor advisory from Ubuntu confirms that fixes have been released for affected Linux kernel versions. No additional mitigation steps are required beyond applying the official kernel updates.

Description

A vulnerability in the Linux kernel's hwmon asus_atk0110 driver allowed an out-of-bounds read due to missing checks on sub-package counts before accessing elements. This flaw was fixed by adding a check to ensure sub-packages are non-empty before access, preventing potential memory corruption. The issue affects specific Linux kernel versions listed and has a CVSS score of 8.4, indicating high severity. A patch is available and should be applied to mitigate the risk.

References

Community reviews

Loading reviews…